Re: [PATCH v2 00/12] object_id part 11 (the_hash_algo)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jan 31, 2018 at 6:18 PM, brian m. carlson
<sandals@xxxxxxxxxxxxxxxxxxxx> wrote:
> This series includes various changes to adopt the use of the_hash_algo
> for abstracting hash algorithms away.

This series looks good to me.

>
> Changes from v1:
> * Fix comments referring to SHA-1.
> * Switch hash function wrappers to take git_hash_ctx *.
> * Use a const int variable for a constant value.
> * Wrap an overly long line.
>
> brian m. carlson (12):
>   hash: move SHA-1 macros to hash.h
>   hash: create union for hash context allocation
>   builtin/index-pack: improve hash function abstraction
>   builtin/unpack-objects: switch uses of SHA-1 to the_hash_algo
>   sha1_file: switch uses of SHA-1 to the_hash_algo
>   fast-import: switch various uses of SHA-1 to the_hash_algo
>   pack-check: convert various uses of SHA-1 to abstract forms
>   pack-write: switch various SHA-1 values to abstract forms
>   read-cache: abstract away uses of SHA-1
>   csum-file: rename sha1file to hashfile
>   csum-file: abstract uses of SHA-1
>   bulk-checkin: abstract SHA-1 usage
>
>  builtin/index-pack.c     | 108 +++++++++++++++++++++++------------------------
>  builtin/pack-objects.c   |  52 +++++++++++------------
>  builtin/unpack-objects.c |  18 ++++----
>  bulk-checkin.c           |  28 ++++++------
>  cache.h                  |  25 -----------
>  csum-file.c              |  46 ++++++++++----------
>  csum-file.h              |  38 ++++++++---------
>  fast-import.c            |  70 +++++++++++++++---------------
>  hash.h                   |  40 +++++++++++++++---
>  pack-bitmap-write.c      |  30 ++++++-------
>  pack-check.c             |  32 +++++++-------
>  pack-write.c             |  77 ++++++++++++++++-----------------
>  pack.h                   |   4 +-
>  read-cache.c             |  58 ++++++++++++-------------
>  sha1_file.c              |  72 +++++++++++++++----------------
>  15 files changed, 351 insertions(+), 347 deletions(-)
>



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux