Re: [PATCH v3 04/14] dir: convert struct sha1_stat to use object_id

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Patryk Obara <patryk.obara@xxxxxxxxx> writes:

> Convert the declaration of struct sha1_stat. Adjust all usages of this
> struct and replace hash{clr,cmp,cpy} with oid{clr,cmp,cpy} wherever
> possible.  Rename it to struct oid_stat.

OK, but a hunk like this makes readers wonder...

> -static int do_read_blob(const struct object_id *oid,
> -			struct sha1_stat *sha1_stat,
> -			size_t *size_out,
> -			char **data_out)
> +static int do_read_blob(const struct object_id *oid, struct oid_stat *sha1_stat,
> +			size_t *size_out, char **data_out)

... why the variable is still called sha1_stat, not oid_stat.  Is it
because it makes the patch too noisy or something?

> Remove macro EMPTY_BLOB_SHA1_BIN, as it's no longer used.

Good.



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux