Hi everyone, This series is a respin of something [1] I sent a few months ago. This time, instead of shell, It's based on top of the C implementation of the interactive rebase. I've also tried to address the comments that were left in the last thread. This series will add the 'rebase.abbreviateCommands' configuration option to allow `git rebase -i` to default to the single-letter command names when generating the todo list. Using single-letter command names can present two benefits. First, it makes it easier to change the action since you only need to replace a single character (i.e.: in vim "r<character>" instead of "ciw<character>"). Second, using this with a large enough value of 'core.abbrev' enables the lines of the todo list to remain aligned making the files easier to read. Changes since last time: - Implement abbreviateCommands in rebase--helper - Add note on the --[no-]autosquash option in rebase.autoSquash - Add exec commands via the rebase--helper - Add test case for rebase.abbreviateCommands Liam Beguin (5): Documentation: move rebase.* configs to new file Documentation: use preferred name for the 'todo list' script rebase -i: add exec commands via the rebase--helper rebase -i: learn to abbreviate command names t3404: add test case for abbreviated commands Documentation/config.txt | 31 +------------ Documentation/git-rebase.txt | 19 +------- Documentation/rebase-config.txt | 51 ++++++++++++++++++++ builtin/rebase--helper.c | 17 +++++-- git-rebase--interactive.sh | 23 +-------- sequencer.c | 100 ++++++++++++++++++++++++++++++++++------ sequencer.h | 5 +- t/t3404-rebase-interactive.sh | 32 +++++++++++++ 8 files changed, 186 insertions(+), 92 deletions(-) create mode 100644 Documentation/rebase-config.txt [1] https://public-inbox.org/git/20170502040048.9065-1-liambeguin@xxxxxxxxx/ -- 2.15.0.321.g19bf2bb99cee.dirty