A lot of BUG() invocations are in the form of if (condition) BUG() so moving the condition into the same line as the macro will result in more readable code. The conversion to use this MACRO will happen in a later patch. This macro in name and spirit is borrowed from linux, which defines it as #define BUG_ON(condition) do { if (unlikely(condition)) BUG(); } while (0) in include/asm-generic/bug.h, however Git prefers to have a more specific message in BUG() calls that we include as well. In case the user doesn't have HAVE_VARIADIC_MACROS, I could not come up with some MACRO trickery to transport the message down to BUG conditionally such that BUG_ON is a function just like BUG() as well. Signed-off-by: Stefan Beller <sbeller@xxxxxxxxxx> --- git-compat-util.h | 4 ++++ usage.c | 12 +++++++++++- 2 files changed, 15 insertions(+), 1 deletion(-) diff --git a/git-compat-util.h b/git-compat-util.h index cedad4d581..4fec462e30 100644 --- a/git-compat-util.h +++ b/git-compat-util.h @@ -1092,9 +1092,13 @@ static inline int regexec_buf(const regex_t *preg, const char *buf, size_t size, __attribute__((format (printf, 3, 4))) NORETURN void BUG_fl(const char *file, int line, const char *fmt, ...); #define BUG(...) BUG_fl(__FILE__, __LINE__, __VA_ARGS__) +#define BUG_ON(condition, ...) do { if (condition) BUG(__VA_ARGS__); } while (0) #else __attribute__((format (printf, 1, 2))) NORETURN void BUG(const char *fmt, ...); + +__attribute__((format (printf, 2, 3))) +void BUG_ON(int condition, const char *fmt, ...); #endif /* diff --git a/usage.c b/usage.c index cdd534c9df..3aed669181 100644 --- a/usage.c +++ b/usage.c @@ -240,7 +240,17 @@ NORETURN void BUG(const char *fmt, ...) BUG_vfl(NULL, 0, fmt, ap); va_end(ap); } -#endif + +void BUG_ON(int condition, const char *fmt, ...) +{ + if (condition) { + va_list ap; + va_start(ap, fmt); + BUG_vfl(NULL, 0, fmt, ap); + va_end(ap); + } +} +#endif /* HAVE_VARIADIC_MACROS */ #ifdef SUPPRESS_ANNOTATED_LEAKS void unleak_memory(const void *ptr, size_t len) -- 2.15.0.448.gf294e3d99a-goog