On 5/24/07, Shawn O. Pearce <spearce@xxxxxxxxxxx> wrote:
Alex Riesen <raa.lkml@xxxxxxxxx> wrote: > On 5/24/07, skimo@xxxxxxxx <skimo@xxxxxxxx> wrote: > >+ if (cmd->clear_git_env) { > >+ unsetenv(ALTERNATE_DB_ENVIRONMENT); > >+ unsetenv(DB_ENVIRONMENT); > >+ unsetenv(CONFIG_ENVIRONMENT); > >+ unsetenv(GIT_DIR_ENVIRONMENT); > >+ unsetenv(GRAFT_ENVIRONMENT); > >+ unsetenv(INDEX_ENVIRONMENT); > >+ } > > You might want to try the alternative approach from the recently > proposed patches to do the same, but more generic. Would > be less code, too. Unfortunately Alex's approach means the caller must know the list of "special Git envvars" that should be cleared when entering into a subproject Git repository to execute a command. That's horrible code duplication in the callers of run_command, and is just asking for trouble later when/if another magic environment variable is added.
#define GIT_ENV_LIST ALTERNATE_DB_ENVIRONMENT, \ ... - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html