This reroll make some logically small changes to v1 [1] that are textually very big: * Invert the sense of `is_packed_transaction_noop()` and rename it to `is_packed_transaction_needed()`. This makes the logic easier to follow and document. * Add a big comment to that function, describing the cases when it returns false positives and explaining why that isn't a problem. * In the commit message for patch 02, gives a lot more information about the regression that it is fixing. Thanks to Eric for the suggestion. These patches are also available as branch `avoid-rewriting-packed-refs` on my GitHub fork [2]. They now use `mh/packed-ref-transactions` as the base, since that is where Junio chose to apply v1. Michael [1] https://public-inbox.org/git/cover.1508924577.git.mhagger@xxxxxxxxxxxx/ [2] https://github.com/mhagger/git Michael Haggerty (2): t1409: check that `packed-refs` is not rewritten unnecessarily files-backend: don't rewrite the `packed-refs` file unnecessarily refs/files-backend.c | 18 ++++++- refs/packed-backend.c | 94 +++++++++++++++++++++++++++++++++ refs/packed-backend.h | 9 ++++ t/t1409-avoid-packing-refs.sh | 118 ++++++++++++++++++++++++++++++++++++++++++ 4 files changed, 238 insertions(+), 1 deletion(-) create mode 100755 t/t1409-avoid-packing-refs.sh -- 2.14.1