On Sat, Sep 23, 2017 at 11:49:16AM +0200, Martin Ågren wrote: > >> void add_object_array_with_path(struct object *obj, const char *name, struct object_array *array, unsigned mode, const char *path); > >> +/* > >> + * Returns NULL if the array is empty. Otherwise, returns the last object > >> + * after removing its entry from the array. Other resources associated > >> + * with that object are left in an unspecified state and should not be > >> + * examined. > >> + */ > >> +struct object *object_array_pop(struct object_array *array); > > > > I'm very happy to see a comment over the declaration here. But I think > > it's a bit more readable if we put a blank line between the prior > > function and the start of that comment. > > Yes, that looks strange. :( I could re-roll and/or ask Junio to fiddle > with it. On closer look, this file is pretty close to documenting all > functions and there are some other comment-formatting issues. So here's > a promise that I'll get back to clean this up more generally in the not > too distant future. Would that be an acceptable punt? :-? Yeah, I don't think it is a show-stopper (and I think there is a reasonable chance Junio will just mark it up as he applies). -Peff