Kaartic Sivaraam <kaarticsivaraam91196@xxxxxxxxx> writes: > -int validate_new_branchname(const char *name, struct strbuf *ref, > - int force, int attr_only) > +int validate_branch_update(const char *name, struct strbuf *ref, > + int could_exist, int clobber_head) "update" to me means something already exists and the caller is asking this function if it is OK to update it, but is that what this function is used for? I do not find the original name too bad, but if I were renaming it, I'd call it ok_to_create_branch(), with the understanding that forcing a recreation of an existing branch falls into the wider definition of "create". Also I'd avoid "could", which can be taken as an optimization hint (i.e. "you usually do not have to worry about this thing to already exist, but I am telling you that for this one call that is not the case and you need to be a bit more careful by spending extra cycles to see if it is and deal with the situation accordingly if it indeed is"), and use "ok" as part of the name for the parameter (or flip the meaning of it and say "create_only" or something).