On Thu, 27 Jul 2017 11:55:46 -0700 Junio C Hamano <gitster@xxxxxxxxx> wrote: > My reading hiccupped after the first sentence, as the problem > description made it sound like this was a boolean ("are we using > lazy object feature?"), after reading "data type string". And then > "the command in that option" made me hiccup one more time, as it did > not "click" that "in that option" was trying to say that the string > is used as the command name (or is it a whole command line? The > leading part of the command line to which some arguments are > appended before it gets invoked as a command? or what?). > > Logically, I think it is more like > > - extensions.lazyobject can be set to tell Git to consider missing > objects in certain cases are not errors; > > - the value of extensions.lazyobject variable must be a string, > which is used to name the command to lazily make the object > "appear" in the repository on demand. OK, I'll update the commit message in the next reroll. > > extern int repository_format_precious_objects; > > +extern char *repository_format_lazy_object; > > This is not a new problem, but I think these two should be > called repository_extension_$NAME not repository_format_$NAME. Looking at the original commit 067fbd4 ("introduce "preciousObjects" repository extension", 2015-06-24), it seems that this was so named to be analogous to the existing "struct repository_format { int version; ...}" => "int repository_format_version;". The existing repository_format_$NAME thus seems reasonable to me.