On Mon, Jun 19, 2017 at 2:50 PM, Prathamesh Chavan <pc44800@xxxxxxxxx> wrote: > The mechanism used for porting the submodule subcommand 'sync' is > similar to that of 'foreach', where we split the function cmd_sync > from shell into three functions in C, module_sync, > for_each_submodule_list and sync_submodule. > > print_default_remote is introduced as a submodule--helper > subcommand for getting the default remote as stdout. > > Mentored-by: Christian Couder <christian.couder@xxxxxxxxx> > Mentored-by: Stefan Beller <sbeller@xxxxxxxxxx> > Signed-off-by: Prathamesh Chavan <pc44800@xxxxxxxxx> > --- Up to this patch, all other patches look good to me, here I stumbled upon a small nit. > builtin/submodule--helper.c | 180 ++++++++++++++++++++++++++++++++++++++++++++ > git-submodule.sh | 56 +------------- > 2 files changed, 181 insertions(+), 55 deletions(-) > > diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c > index 78b21ab22..e10cac462 100644 > --- a/builtin/submodule--helper.c > +++ b/builtin/submodule--helper.c > @@ -43,6 +43,20 @@ static char *get_default_remote(void) > return ret; > } > > +static int print_default_remote(int argc, const char **argv, const char *prefix) > +{ > + const char *remote; > + > + if (argc != 1) > + die(_("submodule--helper print-default-remote takes no arguments")); > + > + remote = get_default_remote(); > + if (remote) > + puts(remote); > + > + return 0; > +} > + > static int starts_with_dot_slash(const char *str) > { > return str[0] == '.' && is_dir_sep(str[1]); > @@ -311,6 +325,25 @@ static int print_name_rev(int argc, const char **argv, const char *prefix) > return 0; > } > > +static char *get_up_path(const char *path) > +{ > + int i = count_slashes(path); > + struct strbuf sb = STRBUF_INIT; > + > + while (i--) > + strbuf_addstr(&sb, "../"); > + > + /* > + *Check if 'path' ends with slash or not > + *for having the same output for dir/sub_dir > + *and dir/sub_dir/ > + */ > + if (!is_dir_sep(path[i - 1])) > + strbuf_addstr(&sb, "../"); > + > + return strbuf_detach(&sb, NULL); > +} > + > struct module_list { > const struct cache_entry **entries; > int alloc, nr; > @@ -736,6 +769,151 @@ static int module_name(int argc, const char **argv, const char *prefix) > return 0; > } > > +struct sync_cb { > + const char *prefix; > + unsigned int quiet: 1; > + unsigned int recursive: 1; > +}; > +#define SYNC_CB_INIT { NULL, 0, 0 } > + > +static void sync_submodule(const struct cache_entry *list_item, void *cb_data) > +{ > + struct sync_cb *info = cb_data; > + const struct submodule *sub; > + char *sub_key, *remote_key; > + char *url, *sub_origin_url, *super_config_url, *displaypath; > + struct strbuf sb = STRBUF_INIT; > + struct child_process cp = CHILD_PROCESS_INIT; > + > + if (!is_submodule_initialized(list_item->name)) > + return; > + > + sub = submodule_from_path(null_sha1, list_item->name); > + > + if (!sub->url) 'sub' can be NULL as well, which when used to obtain the ->url will crash. So we'd rather want to have (!sub || !sub->url). I looked through other use cases, others only need (!sub), so this thought did not hint at other bugs in the code base. > + die(_("no url found for submodule path '%s' in .gitmodules"), > + list_item->name); > + > + url = xstrdup(sub->url); Why do we need to duplicate the url here? As we are not modifying it (read: I did not spot the url modification), we could just use sub->url instead, saving a variable.