Samuel Lijin <sxlijin@xxxxxxxxx> writes: > On Wed, May 24, 2017 at 12:14 AM, Torsten Bögershausen <tboegi@xxxxxx> wrote: >> >>> diff --git a/builtin/clean.c b/builtin/clean.c >>> index d861f836a..937eb17b6 100644 >>> --- a/builtin/clean.c >>> +++ b/builtin/clean.c >>> @@ -857,6 +857,38 @@ static void interactive_main_loop(void) >>> } >>> } >>> +static void correct_untracked_entries(struct dir_struct *dir) >> >> Looking what the function does, would >> drop_or_keep_untracked_entries() >> make more sense ? > > To me, drop_or_keep_ implies that they're either all dropped or all > kept, nothing in between, which is why I went with correct_, to > indicate that the set of untracked entries in the dir_struct prior to > calling the method needs to be corrected. Neither is a particularly good name, but if I have to pick, I'd say we should keep yours. drop-or-keep may indicate some are dropped while others are kept but it does not say what the function is for. correct is better in the sense that the readers can guess that there is something wrong in "dir" at the point and needs correcting by calling the helper, but still does not convey what exactly is wrong. How the wrong-ness is corrected does not have to be explained in the name (i.e. I am saying that drop-or-keep does not give us much useful information), but I wish that the name of the helper hinted what kind of wrongness is there to be corrected to the readers.