Re: [PATCH v1 2/5] Teach git to optionally utilize a file system monitor to speed up detecting new or changed files.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 5/16/2017 5:41 PM, Jonathan Tan wrote:
I'm not very familiar with this part of the code - here is a partial
review.

Firstly, if someone invokes update-index, I wonder if it's better just
to do a full refresh (e.g. by deleting the last_update time from the
index).

A full refresh can be very expensive when the working directory is large (the specific case this patch series is trying to improve). Instead, the code does the minimal update required to keep things fast but still return correct results.


Also, the change to unpack-trees.c doesn't match my mental model. I
notice that it is in a function related to sparse checkout, but if the
working tree changes for whatever reason, it seems simpler to just let
the hook do its thing. As far as I can tell, it is fine to have files
overzealously marked as FSMONITOR_DIRTY.

The case this (and the others like it) is solving is when the index is updated but there may not be any change to the associated file in the working directory. When this occurs, the hook won't indicate any change has happened so the index and working directory could be out of sync. To be sure this doesn't happen, the index entry is marked CE_FSMONITOR_DIRTY to ensure the file is checked.

This is pretty simple to demonstrate - a simple "git reset HEAD~1" will do it as a mixed reset updates the index but doesn't touch the files in the working directory.


On 05/15/2017 12:13 PM, Ben Peart wrote:
diff --git a/cache.h b/cache.h
index 40ec032a2d..64aa6e57cd 100644
--- a/cache.h
+++ b/cache.h
@@ -201,6 +201,7 @@ struct cache_entry {
 #define CE_ADDED             (1 << 19)

 #define CE_HASHED            (1 << 20)
+#define CE_FSMONITOR_DIRTY   (1 << 21)
 #define CE_WT_REMOVE         (1 << 22) /* remove in work directory */
 #define CE_CONFLICTED        (1 << 23)

@@ -324,6 +325,7 @@ static inline unsigned int canon_mode(unsigned int
mode)
 #define CACHE_TREE_CHANGED    (1 << 5)
 #define SPLIT_INDEX_ORDERED    (1 << 6)
 #define UNTRACKED_CHANGED    (1 << 7)
+#define FSMONITOR_CHANGED    (1 << 8)

 struct split_index;
 struct untracked_cache;
@@ -342,6 +344,8 @@ struct index_state {
     struct hashmap dir_hash;
     unsigned char sha1[20];
     struct untracked_cache *untracked;
+    time_t last_update;
+    struct ewah_bitmap *bitmap;

Here a bitmap is introduced, presumably corresponding to the entries in
"struct cache_entry **cache", but there is also a CE_FSMONITOR_DIRTY
that can be set in each "struct cache_entry". This seems redundant and
probably at least worth explaining in a comment.


The ewah bitmap is loaded from the index extension and saved until it can be processed after the untracked cache has been loaded and initialized in post_read_index_from(). I'm not opposed to documenting that to make it clearer but I've just followed the same pattern the untracked cache, and split index extensions use which don't specifically document it either.

+/*
+ * Call the query-fsmonitor hook passing the time of the last saved
results.
+ */
+static int query_fsmonitor(time_t last_update, struct strbuf *buffer)
+{
+    struct child_process cp = CHILD_PROCESS_INIT;
+    char date[64];
+    const char *argv[3];
+
+    if (!(argv[0] = find_hook("query-fsmonitor")))
+        return -1;
+
+    snprintf(date, sizeof(date), "%" PRIuMAX, (uintmax_t)last_update);
+    argv[1] = date;
+    argv[2] = NULL;
+    cp.argv = argv;
+    cp.out = -1;
+
+    return capture_command(&cp, buffer, 1024);
+}

Output argument could probably be named better.

I agree.  I've renamed it query_result for the next iteration.


Also, would the output of this command be very large? If yes, it might
be better to process it little by little instead of buffering the whole
thing first.


The output is usually quite small as it is is the list of files modified in the working directory since the last command that requested the updated list.

+void write_fsmonitor_extension(struct strbuf *sb, struct index_state*
istate);

Space before * (in the .h and .c files).


Thanks, missed that.  I'll fix it for the next iteration.




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]