On 5/10/07, Michael S. Tsirkin <mst@xxxxxxxxxxxxxxxxxx> wrote:
> Quoting Alex Riesen <raa.lkml@xxxxxxxxx>: > Subject: Re: [PATCHv2] connect: display connection progress > > On 5/10/07, Michael S. Tsirkin <mst@xxxxxxxxxxxxxxxxxx> wrote: > >-static int git_tcp_connect_sock(char *host) > >+static int git_tcp_connect_sock(char *host, int flags) > > There is only one bit of flags ever used. What are the others for? Hmm, I thought it's easier to read git_tcp_connect_sock(host, NET_QUIET)
It is easier to read. "int flags" isn't easier to understand.
> Why use negative logic? > What was wrong with plain "int verbose"? I want the default to report connections, and -q to silence them. Maybe "int quiet"?
It depends. "Quiet" is negative, which automatically makes the logic harder to follow (for humans, at least), and you had to put negations all over git_tcp_connect, exactly because the meaning is exactly the opposite to what you need.
> What addresses were tried by connect? You are speaking about your patch reporting the IP on failure?
Yes. Not on failure (not only). Every time an address is tried to connect.
I think it makes sense, but it's a separate issue, isn't it?
You are just about to make git_tcp_connect verbose, are you not? - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html