Rename 'add_sha1_to_array()' to 'append_oid_to_array()' to more accurately describe what the function does since it handles 'struct object_id' and not sha1 character arrays. Change-Id: Ia6d15f34cee4d0dc32f7a475c69f4cb3aa8ce5bf Signed-off-by: Brandon Williams <bmwill@xxxxxxxxxx> --- submodule.c | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/submodule.c b/submodule.c index d3299e29c..be0f5d847 100644 --- a/submodule.c +++ b/submodule.c @@ -951,17 +951,18 @@ static void submodule_collect_changed_cb(struct diff_queue_struct *q, } } -static int add_sha1_to_array(const char *ref, const struct object_id *oid, - int flags, void *data) +static int append_oid_to_array(const char *ref, const struct object_id *oid, + int flags, void *data) { - oid_array_append(data, oid); + struct oid_array *array = data; + oid_array_append(array, oid); return 0; } void check_for_new_submodule_commits(struct object_id *oid) { if (!initialized_fetch_ref_tips) { - for_each_ref(add_sha1_to_array, &ref_tips_before_fetch); + for_each_ref(append_oid_to_array, &ref_tips_before_fetch); initialized_fetch_ref_tips = 1; } -- 2.13.0.rc1.294.g07d810a77f-goog