This applies to origin/master. For better readability and understandability for newcomers it is a good idea to not offer 2 APIs doing the same thing with on being the #define of the other. In the long run we may want to drop the macros guarded by NO_THE_INDEX_COMPATIBILITY_MACROS. This converts a couple of them. My main reason for this patch is to try out coccinelle as well as a discussion I had off list about maintainability of software. I just made these patches and wonder if now is a good time to pull through and convert the rest as well? Thanks, Stefan Stefan Beller (5): cache.h: drop read_cache() cache.h: drop active_* macros cache.h: drop read_cache_from cache.h: drop read_cache_preload(pathspec) cache.h: drop read_cache_unmerged() apply.c | 10 +++---- builtin/add.c | 10 +++---- builtin/am.c | 14 +++++----- builtin/blame.c | 10 +++---- builtin/check-attr.c | 2 +- builtin/check-ignore.c | 4 +-- builtin/checkout-index.c | 10 +++---- builtin/checkout.c | 53 ++++++++++++++++++------------------ builtin/clean.c | 2 +- builtin/commit.c | 32 +++++++++++----------- builtin/describe.c | 2 +- builtin/diff-files.c | 4 +-- builtin/diff-index.c | 6 ++-- builtin/diff.c | 14 +++++----- builtin/fsck.c | 14 +++++----- builtin/grep.c | 10 +++---- builtin/ls-files.c | 38 +++++++++++++------------- builtin/merge-index.c | 12 ++++---- builtin/merge.c | 14 +++++----- builtin/mv.c | 12 ++++---- builtin/pull.c | 2 +- builtin/read-tree.c | 4 +-- builtin/reset.c | 4 +-- builtin/rev-parse.c | 2 +- builtin/rm.c | 18 ++++++------ builtin/submodule--helper.c | 10 +++---- builtin/update-index.c | 52 ++++++++++++++++++----------------- cache.h | 10 ------- check-racy.c | 6 ++-- diff-lib.c | 6 ++-- diff.c | 10 +++---- dir.c | 20 +++++++------- merge-recursive.c | 30 ++++++++++---------- merge.c | 2 +- pathspec.c | 14 +++++----- read-cache.c | 4 +-- rerere.c | 32 +++++++++++----------- revision.c | 22 +++++++-------- sequencer.c | 27 +++++++++--------- sha1_name.c | 16 +++++------ submodule.c | 16 +++++------ t/helper/test-dump-cache-tree.c | 4 +-- t/helper/test-dump-untracked-cache.c | 2 +- t/helper/test-lazy-init-name-hash.c | 10 +++---- t/helper/test-read-cache.c | 2 +- t/helper/test-scrap-cache-tree.c | 4 +-- t/t2107-update-index-basic.sh | 2 +- tree.c | 8 +++--- wt-status.c | 12 ++++---- 49 files changed, 309 insertions(+), 315 deletions(-) -- 2.13.0.rc1.1.gbc33f0f778