On 15/03/17 21:27, Jeff King wrote: > The procedure for moving the ".pack" and the ".idx" files > into place is the same. Rather than repeat the code, let's > factor it into a helper function. > > This has the added benefit of clarifying the lifetime of > "final_pack_name". In the original code it is sometimes > redirected to our reusable "name" buffer; after we reuse > that buffer, the contents are nonsense (but nobody looks at > it, so this is not a bug, just a maintenance issue). In the > new code, the pointer modification is contained in the > helper function. > > Signed-off-by: Jeff King <peff@xxxxxxxx> > --- > builtin/index-pack.c | 40 +++++++++++++++++++--------------------- > 1 file changed, 19 insertions(+), 21 deletions(-) > > diff --git a/builtin/index-pack.c b/builtin/index-pack.c > index f4b87c6c9..187c0550c 100644 > --- a/builtin/index-pack.c > +++ b/builtin/index-pack.c > @@ -1380,6 +1380,23 @@ static void fix_unresolved_deltas(struct sha1file *f) > free(sorted_by_pos); > } > > +static void finalize_file(const char *final_name, const char *curr_name, > + unsigned char *sha1, const char *ext) > +{ > + if (final_name != curr_name) { > + char name[PATH_MAX]; > + if (!final_name) { > + snprintf(name, sizeof(name), "%s/pack/pack-%s.%s", > + get_object_directory(), sha1_to_hex(sha1), > + ext); > + final_name = name; > + } > + if (finalize_object_file(curr_name, final_name)) > + die(_("cannot store %s file"), ext); > + } else if (from_stdin) > + chmod(final_name, 0444); > +} > + > static void final(const char *final_pack_name, const char *curr_pack_name, > const char *final_index_name, const char *curr_index_name, > const char *keep_name, const char *keep_msg, > @@ -1422,27 +1439,8 @@ static void final(const char *final_pack_name, const char *curr_pack_name, > } > } > > - if (final_pack_name != curr_pack_name) { > - if (!final_pack_name) { > - snprintf(name, sizeof(name), "%s/pack/pack-%s.pack", > - get_object_directory(), sha1_to_hex(sha1)); > - final_pack_name = name; > - } > - if (finalize_object_file(curr_pack_name, final_pack_name)) > - die(_("cannot store pack file")); > - } else if (from_stdin) > - chmod(final_pack_name, 0444); > - > - if (final_index_name != curr_index_name) { > - if (!final_index_name) { > - snprintf(name, sizeof(name), "%s/pack/pack-%s.idx", > - get_object_directory(), sha1_to_hex(sha1)); > - final_index_name = name; > - } > - if (finalize_object_file(curr_index_name, final_index_name)) > - die(_("cannot store index file")); > - } else > - chmod(final_index_name, 0444); Is from_stdin always true if final_index_name == curr_index_name? Was the original asymmetry deliberate? > + finalize_file(final_pack_name, curr_pack_name, sha1, "pack"); > + finalize_file(final_index_name, curr_index_name, sha1, "idx"); > > if (!from_stdin) { > printf("%s\n", sha1_to_hex(sha1)); > ATB, Ramsay Jones