On Sat, Feb 25, 2017 at 10:39:29PM +0100, René Scharfe wrote: > > > + (len == 8 && !memcmp(field, "encoding", 8))); > > > > Unrelated, but this could probably be spelled with a macro and strlen() > > to avoid the magic numbers. It would probably be measurably slower for a > > compiler which doesn't pre-compute strlen() on a string literal, though. > > sizeof(string_constant) - 1 might be a better choice here than strlen(). Yeah. If you use a macro, that works. If it's an inline function you'd need strlen(). That's a tradeoff we've already made in skip_prefix_mem() and strip_suffix(), but it's not like we expect this list to grow much, so it may not be worth fussing with. -Peff