Hi Thomas, On Sat, 21 Jan 2017, Thomas Gummerer wrote: > This is the first try to implement the RFC I posted a week ago [1]. It > introduces a new push verb for git stash. I couldn't come up with > any better name that wasn't already taken. If anyone has ideas I'd be > very happy to hear them. I would have preferred a series of patches that essentially adds a new and improved `save` syntax: git stash [save] [-p|--patch] [-k|--[no-]keep-index] [-q|--quiet] [-u|--include-untracked] [-a|--all] [-m <message>]] [-- <path>...] and keeps the legacy syntax, but deprecates it: git stash [save [-p|--patch] [-k|--[no-]keep-index] [-q|--quiet] [-u|--include-untracked] [-a|--all] [<message>]] The problem with that is, of course, that 3c2eb80fe3 (stash: simplify defaulting to "save" and reject unknown options, 2009-08-18) in its infinite wisdom *already* introduced the `--` separator to drop out of option parsing. On a positive note, it is a thorn in Git's CUI that `git stash` implies the `save` command, and that `save` is not at all the opposite of `apply` or `pop`. Your introduction of the `push` command will fix that flaw, and we can *still* deprecate the `save` command. Ciao, Johannes