Am 13.01.2017 um 18:58 schrieb Elia Pinto: > In this patch, instead of using xnprintf instead of snprintf, which asserts > that we don't truncate, we are switching to dynamic allocation with xstrfmt(), > , so we can avoid dealing with magic numbers in the code and reduce the cognitive burden from > the programmers, because they no longer have to count bytes needed for static allocation. > As a side effect of this patch we have also reduced the snprintf() calls, that may silently truncate > results if the programmer is not careful. > > Helped-by: Junio C Hamano <gitster@xxxxxxxxx> > Helped-by: Jeff King <peff@xxxxxxxx> > Signed-off-by: Elia Pinto <gitter.spiros@xxxxxxxxx> > --- > This is the third version of the patch. > > Changes from the first version: I have split the original commit in two, as discussed here > http://public-inbox.org/git/20161213132717.42965-1-gitter.spiros@xxxxxxxxx/. > > Changes from the second version: > - Changed the commit message to clarify the purpose of the patch ( > as suggested by Junio) > https://public-inbox.org/git/xmqqtw95mfo3.fsf@xxxxxxxxxxxxxxxxxxxxxxxxxxx/T/#m2e6405a8a78a8ca1ed770614c91398290574c4a1 > > > > builtin/commit.c | 10 ++++------ > 1 file changed, 4 insertions(+), 6 deletions(-) > > diff --git a/builtin/commit.c b/builtin/commit.c > index 09bcc0f13..37228330c 100644 > --- a/builtin/commit.c > +++ b/builtin/commit.c > @@ -1526,12 +1526,10 @@ static int git_commit_config(const char *k, const char *v, void *cb) > static int run_rewrite_hook(const unsigned char *oldsha1, > const unsigned char *newsha1) > { > - /* oldsha1 SP newsha1 LF NUL */ > - static char buf[2*40 + 3]; > + char *buf; > struct child_process proc = CHILD_PROCESS_INIT; > const char *argv[3]; > int code; > - size_t n; > > argv[0] = find_hook("post-rewrite"); > if (!argv[0]) > @@ -1547,11 +1545,11 @@ static int run_rewrite_hook(const unsigned char *oldsha1, > code = start_command(&proc); > if (code) > return code; > - n = snprintf(buf, sizeof(buf), "%s %s\n", > - sha1_to_hex(oldsha1), sha1_to_hex(newsha1)); > + buf = xstrfmt("%s %s\n", sha1_to_hex(oldsha1), sha1_to_hex(newsha1)); > sigchain_push(SIGPIPE, SIG_IGN); > - write_in_full(proc.in, buf, n); > + write_in_full(proc.in, buf, strlen(buf)); > close(proc.in); > + free(buf); > sigchain_pop(SIGPIPE); > return finish_command(&proc); > } > Perhaps I missed it from the discussion, but why not use strbuf? It would avoid counting the generated string's length. That's probably not going to make a measurable difference performance-wise, but it's easy to avoid and doesn't even take up more lines: --- builtin/commit.c | 10 ++++------ 1 file changed, 4 insertions(+), 6 deletions(-) diff --git a/builtin/commit.c b/builtin/commit.c index 711f96cc43..73bb72016f 100644 --- a/builtin/commit.c +++ b/builtin/commit.c @@ -1525,12 +1525,10 @@ static int git_commit_config(const char *k, const char *v, void *cb) static int run_rewrite_hook(const unsigned char *oldsha1, const unsigned char *newsha1) { - /* oldsha1 SP newsha1 LF NUL */ - static char buf[2*40 + 3]; + struct strbuf sb = STRBUF_INIT; struct child_process proc = CHILD_PROCESS_INIT; const char *argv[3]; int code; - size_t n; argv[0] = find_hook("post-rewrite"); if (!argv[0]) @@ -1546,11 +1544,11 @@ static int run_rewrite_hook(const unsigned char *oldsha1, code = start_command(&proc); if (code) return code; - n = snprintf(buf, sizeof(buf), "%s %s\n", - sha1_to_hex(oldsha1), sha1_to_hex(newsha1)); + strbuf_addf(&sb, "%s %s\n", sha1_to_hex(oldsha1), sha1_to_hex(newsha1)); sigchain_push(SIGPIPE, SIG_IGN); - write_in_full(proc.in, buf, n); + write_in_full(proc.in, sb.buf, sb.len); close(proc.in); + strbuf_release(&sb); sigchain_pop(SIGPIPE); return finish_command(&proc); } -- 2.11.0