Stefan Beller <sbeller@xxxxxxxxxx> writes: > submodule.h: add extern keyword to functions, break line before 80 The former is probably a good change for consistency. As the latter change breaks a workflow around quickly checking the output from "git grep funcname \*.h", I am not sure if it is a good idea. Especially things like this look like a usability regression: -void handle_ignore_submodules_arg(struct diff_options *diffopt, const char *); +extern void handle_ignore_submodules_arg(struct diff_options *diffopt, + const char *); Perhaps the name "diffopt" can be dropped from there if we want it to be shorter. Names in prototypes are valuable for parameters of more generic types like "char *", especially when there are more than one parameters of the same type, but in this case the typename is specific enough for readers to tell what it is.