Re: [PATCH 14/16] checkout: recurse into submodules if asked to

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 11/15, Stefan Beller wrote:
> +int option_parse_recurse_submodules(const struct option *opt,
> +				    const char *arg, int unset)
> +{
> +	if (unset) {
> +		recurse_submodules = RECURSE_SUBMODULES_OFF;
> +		return 0;
> +	}
> +	if (arg)
> +		recurse_submodules =
> +			parse_update_recurse_submodules_arg(opt->long_name,
> +							    arg);
> +	else
> +		recurse_submodules = RECURSE_SUBMODULES_ON;
> +
> +	return 0;
> +}

I assume it is ok to always return 0 from this function?  Also, I know
we don't like having braces on single statement if's but it is a bit
hard to read that multi-line statement without braces.  But that's just
my opinion :)


-- 
Brandon Williams



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]