On Fri, Sep 09, 2016 at 03:47:35PM -0700, Junio C Hamano wrote: > * jk/delta-base-cache (2016-08-23) 7 commits > (merged to 'next' on 2016-08-25 at f1c141a) > + t/perf: add basic perf tests for delta base cache > + delta_base_cache: use hashmap.h > + delta_base_cache: drop special treatment of blobs > + delta_base_cache: use list.h for LRU > + release_delta_base_cache: reuse existing detach function > + clear_delta_base_cache_entry: use a more descriptive name > + cache_or_unpack_entry: drop keep_cache parameter > > The delta-base-cache mechanism has been a key to the performance in > a repository with a tightly packed packfile, but it did not scale > well even with a larger value of core.deltaBaseCacheLimit. I happened to notice today that this topic needs a minor tweak: -- >8 -- Subject: [PATCH] add_delta_base_cache: use list_for_each_safe We may remove elements from the list while we are iterating, which requires using a second temporary pointer. Otherwise stepping to the next element of the list might involve looking at freed memory (which generally works in practice, as we _just_ freed it, but of course is wrong to rely on; valgrind notices it). Signed-off-by: Jeff King <peff@xxxxxxxx> --- sha1_file.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/sha1_file.c b/sha1_file.c index a57b71d..132c861 100644 --- a/sha1_file.c +++ b/sha1_file.c @@ -2187,11 +2187,11 @@ static void add_delta_base_cache(struct packed_git *p, off_t base_offset, void *base, unsigned long base_size, enum object_type type) { struct delta_base_cache_entry *ent = xmalloc(sizeof(*ent)); - struct list_head *lru; + struct list_head *lru, *tmp; delta_base_cached += base_size; - list_for_each(lru, &delta_base_cache_lru) { + list_for_each_safe(lru, tmp, &delta_base_cache_lru) { struct delta_base_cache_entry *f = list_entry(lru, struct delta_base_cache_entry, lru); if (delta_base_cached <= delta_base_cache_limit) -- 2.10.0.230.g6f8d04b