Re: [PATCH 2/3] Define 'crlf' attribute.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

On Fri, 13 Apr 2007, Junio C Hamano wrote:

> diff --git a/attr.c b/attr.c
> index bdbc4a3..d35ae9e 100644
> --- a/attr.c
> +++ b/attr.c
> [...]
> +
> +int git_path_is_binary(const char *path)
> +{
> +	struct git_attr_check attr_binary_check;
> +
> +	setup_binary_check(&attr_binary_check);
> +	return (!git_checkattr(path, 1, &attr_binary_check) &&
> +		(0 < attr_binary_check.isset));
> +}

This function is not declared in a header file, and ...

> diff --git a/convert.c b/convert.c
> index 898bfe3..20c744a 100644
> --- a/convert.c
> +++ b/convert.c
> [...]
> +
> +static int git_path_is_binary(const char *path)
> +{
> +	struct git_attr_check attr_crlf_check;
> +
> +	setup_crlf_check(&attr_crlf_check);
> +
> +	/*
> +	 * If crlf is not mentioned, default to autocrlf;
> +	 * disable autocrlf only when crlf attribute is explicitly
> +	 * unset.
> +	 */
> +	return (!git_checkattr(path, 1, &attr_crlf_check) &&
> +		(0 == attr_crlf_check.isset));
> +}

... here you have a function of the _same_ name, which does something 
subtly different: it checks for "crlf" instead of "binary".

Perhaps you wanted the change to attr.c at a later stage, and the function 
in convert.c should be renamed to "path_wants_crlf()"?

[Reading 3/3 revealed that indeed, the 18 lines in attr.c were unwanted.]

Ciao,
Dscho

-
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]