[PATCH 0/5] Improve test coverage of update-ref error messages

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The logic for deciding what error to emit under various update-ref
failure scenarios is nontrivial. Add a bunch of tests of these error
messages. Then improve a few error messages that were not ideal. One
or two other error messages could still be improved, but that would
take more work so I will skip it for now.

This patch series applies on top of mh/split-under-lock. Improving the
testing of that patch series was in fact the main motivation for this
one. It didn't turn up any serious errors, so I don't think that this
patch series needs to hold up the other one. On the other hand, each
of the patch series changes some error messages, so if possible it
would be preferable to ship them in the same Git release.

Happily, this branch doesn't conflict with either of the other large
patch series that are queued up in this area (mh/ref-iterators [2] and
ref-store [3]).

These patches are also available from my GitHub account [4] as branch
update-ref-errors.

Michael

[1] http://thread.gmane.org/gmane.comp.version-control.git/293800
[2] http://thread.gmane.org/gmane.comp.version-control.git/296322
[3] http://thread.gmane.org/gmane.comp.version-control.git/296409
[4] https://github.com/mhagger/git

Michael Haggerty (5):
  t1404: rename file to t1404-update-ref-errors.sh
  t1404: document function test_update_rejected
  t1404: add more tests of update-ref error handling
  lock_ref_for_update(): make error handling more uniform
  lock_ref_for_update(): avoid a symref resolution

 refs/files-backend.c               |  77 ++++---
 t/t1404-update-ref-df-conflicts.sh | 181 -----------------
 t/t1404-update-ref-errors.sh       | 402 +++++++++++++++++++++++++++++++++++++
 3 files changed, 447 insertions(+), 213 deletions(-)
 delete mode 100755 t/t1404-update-ref-df-conflicts.sh
 create mode 100755 t/t1404-update-ref-errors.sh

-- 
2.8.1

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux