On Fri, Jun 03, 2016 at 07:47:18AM +0000, Elia Pinto wrote: > diff --git a/combine-diff.c b/combine-diff.c > index 8f2313d..a91d9b3 100644 > --- a/combine-diff.c > +++ b/combine-diff.c > @@ -293,7 +293,7 @@ static char *grab_blob(const struct object_id *oid, unsigned int mode, > > if (S_ISGITLINK(mode)) { > blob = xmalloc(100); > - *size = snprintf(blob, 100, > + *size = xsnprintf(blob, 100, > "Subproject commit %s\n", oid_to_hex(oid)); This one seems like a no-brainer to convert to xstrmft(), since we're already using a heap buffer, and then we can get rid of that meaningless "100" magic number. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html