Vasco Almeida <vascomalmeida@xxxxxxx> writes: > Subject: Re: [PATCH 1/7] l10n: index-pack: use plural string instead of normal one These are probably better prefixed with "i18n:" (i.e. enable translation into many languages) not "l10n:" (i.e. actually translate for languages). > Git could output "completed with 1 local objects", but in this case > using "object" instead of "objects" is the correct form. > Use Q_() instead of _(). > > Signed-off-by: Vasco Almeida <vascomalmeida@xxxxxxx> > --- > builtin/index-pack.c | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --git a/builtin/index-pack.c b/builtin/index-pack.c > index 2d1eb8b..e8c71fc 100644 > --- a/builtin/index-pack.c > +++ b/builtin/index-pack.c > @@ -1250,7 +1250,9 @@ static void conclude_pack(int fix_thin_pack, const char *curr_pack, unsigned cha > nr_unresolved * sizeof(*objects)); > f = sha1fd(output_fd, curr_pack); > fix_unresolved_deltas(f); > - strbuf_addf(&msg, _("completed with %d local objects"), > + strbuf_addf(&msg, Q_("completed with %d local object", > + "completed with %d local objects", > + nr_objects - nr_objects_initial), > nr_objects - nr_objects_initial); Looks sensible. It seems that all existing instances of Q_() that have "%d" for the plural one also use "%d" for the singular, so this update is consistent with them. I however wonder if we want to say "completed with 1 local object" in the message, which would allow translation of it into "completed with one local object" etc., but that is a separate topic. Thanks. > stop_progress_msg(&progress, msg.buf); > strbuf_release(&msg); -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html