This patch series adds an --index-only flag to git merge, the idea being to allow a merge to be performed entirely in the index without touching (or even needing) a working tree. The core fix, to merge-recursive, was actually quite easy. The recursive merge logic already had the ability to ignore the working directory and operate entirely on the index -- it needed to do this when creating a virtual merge base, i.e. when o->call_depth > 0. It's just that o->call_depth was also used for other purposes, so I just needed to introduce a new flag to disambiguate and switch all the necessary index-only-related call sites to use it. It actually seems to make the code slightly easier to read too, which is a nice bonus. That was all done in patch 12 of this series. Adding all the necessary testcases and switching over the other merge strategies turned out to be the harder part...and still has a problem, as I'll mention below. A brief-ish summary of the series: * Patches 1 and 2 are unrelated cleanups, which could be submitted independently. However, submitting them as separate patches would result in a minor conflict, so I'm just including them together. * Patches 3 and 4 add some testcases and a fix for a separate issue found while testing this series which could be split off and submitted separately, but fixing this problem and enforcing the starting state I expected permitted me to reduce the range of testcases I needed to consider for the --index-only merges. So I thought it made sense to include in this series. In particular, I was worried about how git merge behaved when the index differed from HEAD prior to the merge starting. I discovered that it wasn't just allowed for fast-forward merges (where behavior is well-defined) but that it was also (accidentally I'm assuming) allowed for octopus merges with weird/surprising behavior. * Patches 5-10 add testcases for the --index-only option for each of the merge strategies/cases: recursive, fast-forward update, resolve, octopus, ours, subtree. * Patch 11 adds the --index-only option to the code and adds the documentation, while patches 12-18 implement the --index-only option for each of the strategies/cases. Some things I am concerned about: * The option name (--index-only) may be slightly misleading since the index isn't the only thing modified within the git directory, other normal things under there are still modified (e.g. writing MERGE_* files, sticking blobs/trees/commits in objects/*, and updating refs and reflogs). I personally prefer this name and think the confusion would be minor, but I'm a bit unsure and wanted some other opinions on this. * I didn't add this option to the separate git-merge-recursive executable and make the worktree-optional modification to the git subcommands merge-recursive, merge-recursive-ours, merge-recursive-theirs, and merge-subtree in git.c. Should I, or are these separate binaries and subcommands just present for historical backward compatibility reasons with people expected to call e.g. "git merge -s recursive" these days? * The addition of --index-only to the various git-merge*.sh scripts is lacking in flexibility (e.g. has to be passed as the first argument). These scripts seemed to have fairly rigid calling conventions already, suggesting there's not much value in making them flexible, but perhaps that was the wrong conclusion to draw. * Expanding on the last item, git-merge-one-file.sh is of particular concern; it seemed to strongly assume exactly seven arguments and that the position of each mattered. I didn't want to break that, so I added --index-only as an optional 8th argument, even though it seems slightly odd force an option argument to always come after positional ones (and it made the changes to merge_entry in merge-index.c slightly easier to implement). Does that seem okay? * For a long time I had two remaining bugs, one of which was in checkout_fast_forward. I was feeling kind of sheepish about that, because how much simpler could it be than handling a fast-forward merge (with possible uncommited index entries to carry forward)? Getting stuck on a simple case like that would be embarrassing. Luckily, I figured out that bug. So, that leaves just one case left that I can't seem to figure out: read_tree_trivial. So much better, right? Even it's name is sitting there, mocking me. "Ha ha, I'm read_tree_*trivial* and you can't figure me out." read_tree_trivial is a jerk. Elijah Newren (18): Remove duplicate code Avoid checking working copy when creating a virtual merge base Document weird bug in octopus merges via testcases merge-octopus: Abort if index not clean Add testcase for --index-only merges needing the recursive strategy Add testcase for --index-only merges needing an ff update Add testcase for --index-only merges with the resolve strategy Add testcase for --index-only merges with the octopus strategy Add testcase for --index-only merges with the ours strategy Add testcase for --index-only merges with the subtree strategy merge: Add a new --index-only option, not yet implemented Add --index-only support for recursive merges Add --index-only support with read_tree_trivial merges, kind of Add --index-only support for ff_only merges merge: Pass --index-only along to external merge strategy programs git-merge-one-file.sh: support --index-only option git-merge-resolve.sh: support --index-only option git-merge-octopus.sh: support --index-only option Documentation/git-merge.txt | 14 + builtin/merge-index.c | 9 +- builtin/merge.c | 13 +- builtin/pull.c | 4 +- cache.h | 3 +- git-merge-octopus.sh | 19 +- git-merge-one-file.sh | 44 ++- git-merge-resolve.sh | 12 +- git.c | 2 +- merge-recursive.c | 40 +-- merge-recursive.h | 1 + merge.c | 8 +- sequencer.c | 4 +- t/t6043-merge-index-only.sh | 443 +++++++++++++++++++++++++++++++ t/t6044-merge-unrelated-index-changes.sh | 156 +++++++++++ 15 files changed, 730 insertions(+), 42 deletions(-) create mode 100755 t/t6043-merge-index-only.sh create mode 100755 t/t6044-merge-unrelated-index-changes.sh -- 2.8.0.18.gc685494 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html