Jeff King <peff@xxxxxxxx> writes: > So it's not wrong, but it's perhaps more complicated than it needs to > be. We could scrap this patch in favor of just: > > if (!skip_prefix(author, "Author: ", &v) && > !skip_prefix(author, "author ", &v)) > continue; > > That is technically more strict (it does not take "author: ", which is > accepted by the current code), but matches "git log" and "git log --raw" > output, and misses nothing that git has ever generated. And it extends > naturally to: > > if (!skip_prefix(author, "Commit: ", &v) && > !skip_prefix(author, "committer ", &v)) > continue; Yeah, I agree that the above long-hand would be more readable. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html