Hi Eric & Junio, On Mon, 11 Jan 2016, Junio C Hamano wrote: > Eric Sunshine <sunshine@xxxxxxxxxxxxxx> writes: > > > I wonder if this would be a bit easier to follow if it was structured > > something like this: > > > > static struct strbuf buf = STRBUF_INIT; > > > > if ((dos_drive_prefix = skip_dos_drive_prefix(&p)) && !*p) > > goto dot; > > > > ... > > if (is_dir_sep(*p)) { > > ... > > } > > ... > > while ((c = *(p++))) > > ... > > > > if (slash) { > > *slash = '\0'; > > return path; > > } > > > > dot: > > strbuf_reset(&buf); > > strbuf_addf(&buf, "%.*s.", dos_drive_prefix, path); > > return buf.buf; > > I'll queue the one from Dscho as-is for today, but avoiding the > "jump back to a place where it happens to have an identical clean-up > that need to happen" and defining the clean-up path at the end like > this would probably be easier to follow. It certainly would have > saved one comment in the previous review cycle from me. Thanks! I changed it and will mail out v4 shortly. Ciao, Dscho -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html