Mike Rappazzo <rappazzo@xxxxxxxxx> writes: > On Sat, Sep 12, 2015 at 10:39 PM, Eric Sunshine <sunshine@xxxxxxxxxxxxxx> wrote: >>> +struct worktree_list *get_worktree_list() >> >> Can we be more concise and call this get_worktrees()? > > I prefer 'get_worktree_list' because I also added the 'get_worktree' > function, and I wanted to differentiate > the function names. I'd say that plural can be differentiating enough; it probably is a matter of taste. How often do external callers want to call get_worktree() and not get_worktrees()? >>> diff --git a/worktree.h b/worktree.h >>> new file mode 100644 >>> index 0000000..2bc0ab8 >>> --- /dev/null >>> +++ b/worktree.h >>> @@ -0,0 +1,48 @@ >>> +#ifndef WORKTREE_H >>> +#define WORKTREE_H >>> + >>> +struct worktree { >>> + char *path; >>> + char *git_dir; >>> + char *head_ref; >>> + unsigned char head_sha1[20]; >>> + int is_detached; >>> + int is_bare; >>> +}; >>> + >>> +struct worktree_list { >>> + struct worktree *worktree; >>> + struct worktree_list *next; >>> +}; >> >> I don't care too strongly, but an alternate approach (which I probably >> would have taken) would be to have get_worktrees() simply return an >> array of 'struct worktree' objects, hence no need for the additional >> 'struct worktree_list'. I do not think we are using this to hold thousands of worktree objects in core. Adding "struct worktree *next" pointer to the worktree object itself would probably be sufficient for the need of codepaths that want to enumerate and iterate over them and that would be another way to lose the extra structure. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html