On Tue, Jul 28, 2015 at 5:23 PM, David Turner <dturner@xxxxxxxxxxxxxxxx> wrote: > Prevent merges to the same notes branch from different worktrees. > Before creating NOTES_MERGE_REF, check NOTES_MERGE_REF using the same > code we use to check that two HEADs in different worktrees don't point > to the same branch. Modify that code, die_if_checked_out, to take a > "head" ref to examine; previously, it just looked at HEAD. die_if_checked_out() seems to be grossly misnamed following this change since a branch (or detached head) can be "checked out", but asking it if a HEAD or NOTES_MERGE_REF is "checked out" sounds weird. Perhaps rename it to die_if_symref_shared() or something? The new argument order, die_if_checked_out("HEAD", "branchname"), also seems backward to me, at least with the current function name (die_if_checked_out). With a better function name, maybe it wouldn't be so bad. I could also see die_if_checked_out() being refactored to move the underlying logic to a new (better named) function for checking the value of a particular file (HEAD, NOTES_MERGE_REF) in each linked worktree. And then die_if_checked_out() would be a thin wrapper over that new function. A reason for preferring this approach and keeping die_if_checked_out() as a convenience wrapper is that it's likely that it's going to be needed in more places in the future. > Reported-by: Junio C Hamano <gitster@xxxxxxxxx> > Signed-off-by: David Turner <dturner@xxxxxxxxxxxxxxxx> > --- > diff --git a/branch.c b/branch.c > index c85be07..60eadc6 100644 > --- a/branch.c > +++ b/branch.c > @@ -311,21 +311,22 @@ void remove_branch_state(void) > unlink(git_path("SQUASH_MSG")); > } > > -static void check_linked_checkout(const char *branch, const char *id) > +static void check_linked_checkout(const char *head, const char *branch, > + const char *id) > { > struct strbuf sb = STRBUF_INIT; > struct strbuf path = STRBUF_INIT; > struct strbuf gitdir = STRBUF_INIT; > > /* > - * $GIT_COMMON_DIR/HEAD is practically outside > + * $GIT_COMMON_DIR/$head is practically outside > * $GIT_DIR so resolve_ref_unsafe() won't work (it > * uses git_path). Parse the ref ourselves. > */ > if (id) > - strbuf_addf(&path, "%s/worktrees/%s/HEAD", get_git_common_dir(), id); > + strbuf_addf(&path, "%s/worktrees/%s/%s", get_git_common_dir(), id, head); > else > - strbuf_addf(&path, "%s/HEAD", get_git_common_dir()); > + strbuf_addf(&path, "%s/%s", get_git_common_dir(), head); > > if (!strbuf_readlink(&sb, path.buf, 0)) { > if (!starts_with(sb.buf, "refs/") || > @@ -356,13 +357,13 @@ done: > strbuf_release(&gitdir); > } > > -void die_if_checked_out(const char *branch) > +void die_if_checked_out(const char *head, const char *branch) > { > struct strbuf path = STRBUF_INIT; > DIR *dir; > struct dirent *d; > > - check_linked_checkout(branch, NULL); > + check_linked_checkout(head, branch, NULL); > > strbuf_addf(&path, "%s/worktrees", get_git_common_dir()); > dir = opendir(path.buf); > @@ -373,7 +374,7 @@ void die_if_checked_out(const char *branch) > while ((d = readdir(dir)) != NULL) { > if (!strcmp(d->d_name, ".") || !strcmp(d->d_name, "..")) > continue; > - check_linked_checkout(branch, d->d_name); > + check_linked_checkout(head, branch, d->d_name); > } > closedir(dir); > } > diff --git a/branch.h b/branch.h > index 58aa45f..3577fe5 100644 > --- a/branch.h > +++ b/branch.h > @@ -57,6 +57,6 @@ extern int read_branch_desc(struct strbuf *, const char *branch_name); > * worktree and die (with a message describing its checkout location) if > * it is. > */ > -extern void die_if_checked_out(const char *branch); > +extern void die_if_checked_out(const char *head, const char *branch); > > #endif -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html