check_linked_checkouts() doesn't just "check" linked checkouts for "something"; specifically, it aborts the operation if the branch about to be checked out is already checked out elsewhere. Therefore, rename it to die_if_checked_out() to give a better indication of its function. The more meaningful name will be particularly important when this function is later published for use by other callers. Signed-off-by: Eric Sunshine <sunshine@xxxxxxxxxxxxxx> --- builtin/checkout.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/builtin/checkout.c b/builtin/checkout.c index 75f90a9..e75fb5e 100644 --- a/builtin/checkout.c +++ b/builtin/checkout.c @@ -910,7 +910,7 @@ done: strbuf_release(&gitdir); } -static void check_linked_checkouts(struct branch_info *new) +static void die_if_checked_out(struct branch_info *new) { struct strbuf path = STRBUF_INIT; DIR *dir; @@ -1152,7 +1152,7 @@ static int checkout_branch(struct checkout_opts *opts, char *head_ref = resolve_refdup("HEAD", 0, sha1, &flag); if (head_ref && (!(flag & REF_ISSYMREF) || strcmp(head_ref, new->path))) - check_linked_checkouts(new); + die_if_checked_out(new); free(head_ref); } -- 2.5.0.rc1.201.ga12d9f8 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html