Karthik Nayak <karthik.188@xxxxxxxxx> writes: > +int parse_opt_merge_filter(const struct option *opt, const char *arg, int unset) > +{ > + struct ref_filter *rf = opt->value; > + unsigned char sha1[20]; > + > + rf->merge = opt->long_name[0] == 'n' > + ? REF_FILTER_MERGED_OMIT > + : REF_FILTER_MERGED_INCLUDE; > + > + if (!arg) > + arg = "HEAD"; > + if (get_sha1(arg, sha1)) > + die(_("malformed object name %s"), arg); > + > + rf->merge_commit = lookup_commit_reference_gently(sha1, 0); > + if (!rf->merge_commit) > + return opterror(opt, "must point to a commit", 0); > + > + return 0; > +} Again, this smells too specific to live as a part of parse-options infrastructure. If we want to have two helper callbacks, one that gives the results in an sha1-array (because there is no guarantee that you want only commits) and in a commit-list, I am fine with having parse_opt_object_name() and parse_opt_with_commit(). Perhaps rename the latter which was named too specifically to something more sensible (e.g. parse_opt_commit_object_name()) and use it from the caller you wanted to use parse_opt_merge_filter()? The caller, if it is not prepared to see more than one commits specified, may have to check if (!list || !list->next) { die("I want one and only one") } or something, though. Having it in ref-filter.h as parse_opt_merge_filter() is fine, though. After all, you would be sharing it with for-each-ref, branch and tag and nobody else anyway. > diff --git a/parse-options.h b/parse-options.h > index 3ae16a1..7bcf0f3 100644 > --- a/parse-options.h > +++ b/parse-options.h > @@ -221,6 +221,7 @@ extern int parse_opt_expiry_date_cb(const struct option *, const char *, int); > extern int parse_opt_color_flag_cb(const struct option *, const char *, int); > extern int parse_opt_verbosity_cb(const struct option *, const char *, int); > extern int parse_opt_points_at(const struct option *, const char *, int); > +extern int parse_opt_merge_filter(const struct option *, const char *, int); > extern int parse_opt_with_commit(const struct option *, const char *, int); > extern int parse_opt_tertiary(const struct option *, const char *, int); > extern int parse_opt_string_list(const struct option *, const char *, int); > @@ -243,5 +244,15 @@ extern int parse_opt_noop_cb(const struct option *, const char *, int); > OPT_COLOR_FLAG(0, "color", (var), (h)) > #define OPT_COLUMN(s, l, v, h) \ > { OPTION_CALLBACK, (s), (l), (v), N_("style"), (h), PARSE_OPT_OPTARG, parseopt_column_callback } > +#define OPT_NO_MERGED(filter, h) \ > + { OPTION_CALLBACK, 0, "no-merged", (filter), N_("commit"), (h), \ > + PARSE_OPT_LASTARG_DEFAULT | PARSE_OPT_NONEG, \ > + parse_opt_merge_filter, (intptr_t) "HEAD" \ > + } > +#define OPT_MERGED(filter, h) \ > + { OPTION_CALLBACK, 0, "merged", (filter), N_("commit"), (h), \ > + PARSE_OPT_LASTARG_DEFAULT | PARSE_OPT_NONEG, \ > + parse_opt_merge_filter, (intptr_t) "HEAD" \ > + } Likewise. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html