Johannes Schindelin <johannes.schindelin@xxxxxx> writes: >> + verbose test "$(git rev-parse HEAD)" = "$(git rev-parse c1)" > > Given that Junio objected to this "verbose test", maybe you want to remove the "verbose"? Or introduce a `test_assert_equal` of the form > > ```sh > test_assert_equal () { > test "a$1" = "a$2" || { > echo "$1 != $2" >&2 > false > } > } > ``` > > Hmm. Now that I think about it, `test_eq` is probably a better name, still. I do not think using "two strings" check for that one is very useful. You cannot tell where two 40-HEX came from. And that is why I suggested "-i -v -x". By the way, I cannot think of a reason why your CI cannot always run the tests with GIT_TEST_OPTS="-v -x" exported. > For the sake of having better reporting, say, in Continuous Integration (where re-running tests via `sh -x t????-*.sh -i -v` -- as Junio suggested -- is not an option), I agree that it would be good to report the non-matching strings. > > Ciao, > Dscho -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html