On Thu, May 7, 2015 at 2:48 PM, Lars Kellogg-Stedman <lars@xxxxxxxxxx> wrote: > On Thu, May 07, 2015 at 02:41:07PM -0400, Eric Sunshine wrote: >> > + if (ssl_cipherlist != NULL && ssl_cipherlist[0] != '\0') >> >> In git code, this is usually spelled: >> >> if (ssl_cipherlist && *ssl_cipherlist) > > Huh. At least in http.c, explicit checks against NULL seem more > common: > > if (ssl_cert != NULL) > if (ssl_key != NULL) > if (ssl_capath != NULL) > > Etc. I was just trying to make the new code look like the existing > code. If nobody else has an opinion on this, I'm inclined to leave > the first clause as-is so that it matches and change the check for an > empty string. Sounds good. Matching existing style makes sense. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html