v3 of the patch can be found here: http://thread.gmane.org/gmane.comp.version-control.git/267422 Changes in v4: * changed some tests to use more meaningful dir names. * fixed performance test by doing "git clean -n" to avoid timing setup code. Increased test size to 100000 directories (~0.5s runtime). * changed interface of read_gitfile_gently to be able to return error code. * fixed a compiler warning in read_gitfile_gently ("warning: ‘dir’ may be used uninitialized in this function"). * added sanity check of git file size in read_gitfile_gently * updated commit message in [5/5] to more clearly motivate remaining behavioral changes of git clean. Thanks to Junio C Hamano and Jeff King for comments and help on v3. Erik Elfström (5): setup: add gentle version of read_gitfile setup: sanity check file size in read_gitfile_gently t7300: add tests to document behavior of clean and nested git p7300: add performance tests for clean clean: improve performance when removing lots of directories builtin/clean.c | 26 +++++++++-- cache.h | 3 +- setup.c | 88 ++++++++++++++++++++++++++++------- t/perf/p7300-clean.sh | 31 +++++++++++++ t/t7300-clean.sh | 126 ++++++++++++++++++++++++++++++++++++++++++++++++++ 5 files changed, 252 insertions(+), 22 deletions(-) create mode 100755 t/perf/p7300-clean.sh -- 2.4.0.rc3.8.g4ebd28d -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html