Hi, On Fri, 2 Mar 2007, Paolo Bonzini wrote: > > Of course you would have to move "int removing" and the related two > > lines to rename_section(), too. > > > > The diff would be shorter, and if you then rename the function to > > rename_or_remove_section() it becomes all clearer. > > It's more different than it looks like. For example, remove_section needs this, > > if (buf[i] == '[') { > if (section_name_match (&buf[i + 1], name)) { > } else > ... > } > > while rename_section can use > > if (buf[i] == '[' && section_name_match (&buf[i+1], old_name)) { But it does not have to. if (buf[i] == '[') { if (section_name_match(&buf[i + 1], old_name) { if (new_name == NULL) remove = 1; else /* write new section */ continue; } remove = 0; } if (!remove) /* write buf */ Ciao, Dscho - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html