Andy Parkins <andyparkins@xxxxxxxxx> writes: > On Thursday 2007 March 01 07:18, Junio C Hamano wrote: > >> [pathattr "text/plain"] >> conv_i = crlf >> path = "*.txt" >> path = "*.c" >> path = "*.h" > > Can I suggest that "crlf" is not the right name for something like this? What > you actually want is to say > > conv_i = convert_from_local_lineendings > conv_o = convert_to_local_lineendings The sample traits' value "crlf" is probably a misnomer. As you noticed, they are to _force_ the conversion. You can add one that honors core.autocrlf (which would be set to true on Windows and to false on UNIX). > conv_i = eol_to_lf > conv_o = eol_to_local Probably. > --- Wild rantings start here, ignore at will --- Will ignore for now, since I have more interesting patches coming for your enjoyment ;-). - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html