> --- a/cache.h > +++ b/cache.h > @@ -1010,6 +1010,7 @@ extern int read_ref(const char *refname, unsigned char *sha1); > * Caps and underscores refers to the special refs, such as HEAD, > * FETCH_HEAD and friends, that all live outside of the refs/ directory. > */ What happened to the comment line ? Should it go away or better stay ? When we move the definition to a common file, it is not 100% clear what MAXDEPTH is about, and the comment is even more important, I think: > +/* We allow "recursive" symbolic links. Only within reason, though. */ > +#define MAXDEPTH 5 On the other hand, if we find a better name for that definition, we may skip the comment. A first suggestion may be #define MAXDEPTH_FOR_SYMLINKS 5 but other variants are possible. -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html