The patch [PATCH 4/7] receive-pack.c: receive-pack.c: use a single ref_transaction for atomic pushes was dropped and redone as 3 separate patches. This wasn't just done for doing it, but the end result has also changed. We have more smaller functions doing one thing instead of these larger functions. Thanks for the ideas, Eric! Also the advertisement of the atomic capabilites was moved to a later new patch in this series. This helps when you want to bisect this series later. Thanks Michael for pointing this out! Thanks, Stefan Ronnie Sahlberg (3): receive-pack.c: add documentation for atomic push support send-pack.c: add --atomic command line argument push.c: add an --atomic argument Stefan Beller (6): send-pack: Rename ref_update_to_be_sent to check_to_send_update receive-pack.c: simplify execute_commands receive-pack.c: move transaction handling in a central place receive-pack.c: add execute_commands_atomic function receive-pack.c: enable atomic push protocol support t5543-atomic-push.sh: add basic tests for atomic pushes Documentation/git-push.txt | 7 +- Documentation/git-send-pack.txt | 7 +- Documentation/technical/protocol-capabilities.txt | 13 +- builtin/push.c | 5 + builtin/receive-pack.c | 154 +++++++++++++++---- builtin/send-pack.c | 6 +- remote.h | 3 +- send-pack.c | 65 +++++++- send-pack.h | 3 +- t/t5543-atomic-push.sh | 178 ++++++++++++++++++++++ transport.c | 5 + transport.h | 1 + 12 files changed, 404 insertions(+), 43 deletions(-) create mode 100755 t/t5543-atomic-push.sh -- 2.2.1.62.g3f15098 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html