This is a re-roll of v1 [1] with the following changes: * Fix some nits in the commit message and comment change in patch 4/7 that were pointed out by Jonathan. * Add a new patch 7/7 that renames sort_string_list() to string_list_sort() as suggested by Junio. I would have submitted the name change as a separate patch, but since this patch series uses the function the two series would have conflicted. Since I didn't see any other patch series in-flight that use sort_string_list(), I just renamed the function everywhere rather than going to the trouble of deprecating the old function and adding the new function. Thanks to Junio, Jonathan, and Stefan for their reviews of v1. [1] http://thread.gmane.org/gmane.comp.version-control.git/259831/focus=260030 Michael Haggerty (7): prune_remote(): exit early if there are no stale references prune_remote(): initialize both delete_refs lists in a single loop prune_remote(): sort delete_refs_list references en masse repack_without_refs(): make the refnames argument a string_list prune_remote(): rename local variable prune_remote(): iterate using for_each_string_list_item() Rename sort_string_list() to string_list_sort() Documentation/technical/api-string-list.txt | 4 +- builtin/apply.c | 2 +- builtin/receive-pack.c | 2 +- builtin/remote.c | 69 +++++++++++++---------------- builtin/repack.c | 2 +- connect.c | 2 +- notes.c | 2 +- refs.c | 38 ++++++++-------- refs.h | 10 ++++- remote.c | 6 +-- sha1_file.c | 2 +- string-list.c | 4 +- string-list.h | 2 +- 13 files changed, 75 insertions(+), 70 deletions(-) -- 2.1.3 -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html