On Mon, Sep 22, 2014 at 11:26:14PM -0700, Junio C Hamano wrote: > On Mon, Sep 22, 2014 at 11:04 PM, Jeff King <peff@xxxxxxxx> wrote: > > > > I don't mind silencing this one warning (even though I find it a little > > ridiculous). I'm slightly concerned that more brain-damage may be coming > > our way, but we can deal with that if it ever does. > > > > Like Junio, I prefer keeping strlen() rather than switching to sizeof, > > as it is less error-prone (no need for extra "-1" dance, and it won't > > silently do the wrong thing if the array is ever converted to a > > pointer). > > I actually do not mind losing the sample[] array too much. > > The early 45 bytes or so of that array (or a string constant) is not used > by the code at all; I didn't want to count "From " (that's 5), 40-hex and > then a SP -- ah, see, it is 46 bytes and I didn't want such miscounting. > The only real contents that matter in that sample[] array is the tail part > that is meant as the magic(5) cue. I'd be OK if the code checked the > length of the line against a hardcoded constant and then did strcmp() > starting from a hardcoded offset of the string and the magic cue string, > and that would also avoid the warning from Eric's compiler. > > But personally, I think the way it is coded is much easier to read, > and is much harder to get it wrong while maintaining it. So... I agree. I was going to suggest switching to a static const array instead of a string literal, but retaining strlen()...but I see you already queued that in pu. So if what is there works for Eric (I do not have the compiler in question to test with), that seems reasonable. -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html