Tanay Abhra <tanayabh@xxxxxxxxx> writes: > +void git_die_config(const char *key) > +{ > + const struct string_list *values; > + struct key_value_info *kv_info; > + values = git_config_get_value_multi(key); > + kv_info = values->items[values->nr - 1].util; > + if (!kv_info->linenr) > + die(_("unable to parse '%s' from command-line config"), key); > + else > + die(_("bad config variable '%s' at file line %d in %s"), > + key, > + kv_info->linenr, > + kv_info->filename); > + } Extra whitespace before }. Also, didn't we agree that it was a good thing to factor this if/then/else into a helper function? -- Matthieu Moy http://www-verimag.imag.fr/~moy/ -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html