Andy Parkins <andyparkins@xxxxxxxxx> writes: > Your prefixcmp() point about them being used so regularly made me wonder if > the following would improve readability: > > static inline ref_is_head(const char *a) > { > return (prefixcmp(a, PATH_REFS_HEADS) == 0); > } > ... > if (ref_is_head(head)) > head += STRLEN_PATH_REFS_HEADS; > > which expresses the intent of the code far more clearly. If we _were_ doing the inline function, I would actually prefer: static inline ref_is_head(const char *ref) { return !prefixcmp(ref, PATH_REFS_HEADS); } But at least to me, if (!prefixcmp(head, PATH_REFS_HEADS)) head += strlen(PATH_REFS_HEADS); is easier to follow than: if (ref_is_head(head)) head += STRLEN_PATH_REFS_HEADS; - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html