Rename cache_def_free to cache_def_clear as it doesn't free the struct cache_def, but just clears its content. Signed-off-by: Karsten Blees <blees@xxxxxxx> --- cache.h | 2 +- preload-index.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/cache.h b/cache.h index 44aa439..378ee7f 100644 --- a/cache.h +++ b/cache.h @@ -1096,7 +1096,7 @@ struct cache_def { int prefix_len_stat_func; }; #define CACHE_DEF_INIT { STRBUF_INIT, 0, 0, 0 } -static inline void cache_def_free(struct cache_def *cache) +static inline void cache_def_clear(struct cache_def *cache) { strbuf_release(&cache->path); } diff --git a/preload-index.c b/preload-index.c index 79ce8a9..c1fe3a3 100644 --- a/preload-index.c +++ b/preload-index.c @@ -63,7 +63,7 @@ static void *preload_thread(void *_data) continue; ce_mark_uptodate(ce); } while (--nr > 0); - cache_def_free(&cache); + cache_def_clear(&cache); return NULL; } -- 2.0.1.563.g66f467c.dirty -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html