Jeff King <peff@xxxxxxxx> writes: > I know this is existing code you are moving, but I noticed it looks ripe > for using skip_prefix. Perhaps while we are in the area we should do the > following on top of your patch (I'd also be happy for it be squashed > in, but that may be too much in one patch). I am tempted to suggest going the other way around, i.e. queue (an equivalent of) this on jk/skip-prefix and merge it to 'next' and then 'master' quickly. I can go either way, but I tend to prefer building new things on top of obviously correct clean-up, not the other way around. > -- >8 -- > Subject: [PATCH] tag: use skip_prefix instead of magic numbers > > We can make the parsing of the --sort parameter a bit more > readable by having skip_prefix keep our pointer up to date. > > Signed-off-by: Jeff King <peff@xxxxxxxx> builtin/tag.c | 14 +++++--------- 1 file changed, 5 insertions(+), 9 deletions(-) diff --git a/builtin/tag.c b/builtin/tag.c index c6e8a71..1101c19 100644 --- a/builtin/tag.c +++ b/builtin/tag.c @@ -524,18 +524,14 @@ static int parse_opt_sort(const struct option *opt, const char *arg, int unset) int *sort = opt->value; int flags = 0; - if (*arg == '-') { + if (skip_prefix(arg, "-", &arg)) flags |= REVERSE_SORT; - arg++; - } - if (starts_with(arg, "version:")) { - *sort = VERCMP_SORT; - arg += 8; - } else if (starts_with(arg, "v:")) { + + if (skip_prefix(arg, "version:", &arg) || skip_prefix(arg, "v:", &arg)) *sort = VERCMP_SORT; - arg += 2; - } else + else *sort = STRCMP_SORT; + if (strcmp(arg, "refname")) die(_("unsupported sort specification %s"), arg); *sort |= flags; -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html