Re: [PATCH v6 29/32] gc: support prune --repos

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jul 9, 2014 at 3:33 AM, Nguyễn Thái Ngọc Duy <pclouds@xxxxxxxxx> wrote:
> Signed-off-by: Nguyễn Thái Ngọc Duy <pclouds@xxxxxxxxx>
> ---
>  Documentation/config.txt |  7 +++++++
>  builtin/gc.c             | 17 +++++++++++++++++
>  2 files changed, 24 insertions(+)
>
> diff --git a/Documentation/config.txt b/Documentation/config.txt
> index 286e539..470f979 100644
> --- a/Documentation/config.txt
> +++ b/Documentation/config.txt
> @@ -1211,6 +1211,13 @@ gc.pruneexpire::
>         "now" may be used to disable this  grace period and always prune
>         unreachable objects immediately.
>
> +gc.prunereposexpire::
> +       When 'git gc' is run, it will call
> +       'prune --repos --expire 3.months.ago'.
> +       Override the grace period with this config variable. The value
> +       "now" may be used to disable the grace period and always prune
> +       $GIT_DIR/repos immediately.

nit: This reads very slightly better without "always":

    ... disable the grace period and prune [...] immediately.

More below.

> +
>  gc.reflogexpire::
>  gc.<pattern>.reflogexpire::
>         'git reflog expire' removes reflog entries older than
> diff --git a/builtin/gc.c b/builtin/gc.c
> index 53f1302..1190183 100644
> --- a/builtin/gc.c
> +++ b/builtin/gc.c
> @@ -33,11 +33,13 @@ static int gc_auto_threshold = 6700;
>  static int gc_auto_pack_limit = 50;
>  static int detach_auto = 1;
>  static const char *prune_expire = "2.weeks.ago";
> +static const char *prune_repos_expire = "3.months.ago";
>
>  static struct argv_array pack_refs_cmd = ARGV_ARRAY_INIT;
>  static struct argv_array reflog = ARGV_ARRAY_INIT;
>  static struct argv_array repack = ARGV_ARRAY_INIT;
>  static struct argv_array prune = ARGV_ARRAY_INIT;
> +static struct argv_array prune_repos = ARGV_ARRAY_INIT;
>  static struct argv_array rerere = ARGV_ARRAY_INIT;
>
>  static char *pidfile;
> @@ -92,6 +94,14 @@ static int gc_config(const char *var, const char *value, void *cb)
>                 }
>                 return git_config_string(&prune_expire, var, value);
>         }
> +       if (!strcmp(var, "gc.prunereposexpire")) {
> +               if (value && strcmp(value, "now")) {
> +                       unsigned long now = approxidate("now");
> +                       if (approxidate(value) >= now)
> +                               return error(_("Invalid %s: '%s'"), var, value);
> +               }
> +               return git_config_string(&prune_repos_expire, var, value);

This logic is copied from the "gc.pruneexpire" case immediately above
it. Would it make sense to factor it out into a helper function (or is
it not worth the bother for just two cases)?

> +       }
>         return git_default_config(var, value, cb);
>  }
>
> @@ -299,6 +309,7 @@ int cmd_gc(int argc, const char **argv, const char *prefix)
>         argv_array_pushl(&reflog, "reflog", "expire", "--all", NULL);
>         argv_array_pushl(&repack, "repack", "-d", "-l", NULL);
>         argv_array_pushl(&prune, "prune", "--expire", NULL);
> +       argv_array_pushl(&prune_repos, "prune", "--repos", "--expire", NULL);
>         argv_array_pushl(&rerere, "rerere", "gc", NULL);
>
>         git_config(gc_config, NULL);
> @@ -368,6 +379,12 @@ int cmd_gc(int argc, const char **argv, const char *prefix)
>                         return error(FAILED_RUN, prune.argv[0]);
>         }
>
> +       if (prune_repos_expire) {
> +               argv_array_push(&prune_repos, prune_repos_expire);
> +               if (run_command_v_opt(prune_repos.argv, RUN_GIT_CMD))
> +                       return error(FAILED_RUN, prune_repos.argv[0]);
> +       }
> +
>         if (run_command_v_opt(rerere.argv, RUN_GIT_CMD))
>                 return error(FAILED_RUN, rerere.argv[0]);
>
> --
> 1.9.1.346.ga2b5940
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]