Hi, I was about to send a patch like this series today, I am attaching it below. -- >8 -- Subject: [PATCH] imap-send: use skip_prefix instead of using magic numbers Signed-off-by: Tanay Abhra <tanayabh@xxxxxxxxx> --- imap-send.c | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-) diff --git a/imap-send.c b/imap-send.c index 83a6ed2..524fbab 100644 --- a/imap-send.c +++ b/imap-send.c @@ -1328,13 +1328,9 @@ static char *imap_folder; static int git_imap_config(const char *key, const char *val, void *cb) { - char imap_key[] = "imap."; - - if (strncmp(key, imap_key, sizeof imap_key - 1)) + if (!skip_prefix(key, "imap.", &key)) return 0; - key += sizeof imap_key - 1; - /* check booleans first, and barf on others */ if (!strcmp("sslverify", key)) server.ssl_verify = git_config_bool(key, val); -- 1.9.0.GIT -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html