René Scharfe wrote: > Signed-off-by: Rene Scharfe <l.s.r@xxxxxx> > --- > builtin/blame.c | 28 ++++++++++------------------ > 1 file changed, 10 insertions(+), 18 deletions(-) Reviewed-by: Jonathan Nieder <jrnieder@xxxxxxxxx> [...] > + for (p = get_next_line(buf, end); p; p = get_next_line(p, end)) > + num++; This could say something like for (p = buf; p = get_next_line(buf, end); ) { num++; or p = buf; while ((p = memchr(p, '\n', end - p))) { p++; num++; } but what you have seems more readable. Thanks, Jonathan -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html