dturner@xxxxxxxxxxxxxxxx writes: > From: David Turner <dturner@xxxxxxxxxxx> > > Make it possible to change the case of a filename on a > case-insensitive filesystem using git mv. Change git mv to allow > moves where the destination file exists if the destination file has > the same name as the source file ignoring case. > > Signed-off-by: David Turner <dturner@xxxxxxxxxxx> > --- > builtin/mv.c | 3 ++- > t/t6039-merge-ignorecase.sh | 2 +- > 2 files changed, 3 insertions(+), 2 deletions(-) > > diff --git a/builtin/mv.c b/builtin/mv.c > index 45e57f3..f4d89d0 100644 > --- a/builtin/mv.c > +++ b/builtin/mv.c > @@ -202,7 +202,8 @@ int cmd_mv(int argc, const char **argv, const char *prefix) > } > } else if (cache_name_pos(src, length) < 0) > bad = _("not under version control"); > - else if (lstat(dst, &st) == 0) { > + else if (lstat(dst, &st) == 0 && > + (!ignore_case || strcasecmp(src, dst))) { Hmm, I would find it easier to read if it were: ... if (lstat(dst, &st) == 0 && !(ignore_case && !strcasecmp(src, dst))) { That is, "it is an error for dst to exist, unless we are on a case insensitive filesystem and src and dst refer to the same file.", but maybe it is just me. More importantly, what is the end-user visible effect of this change? Is it fair to summarize it like this? On a case-insensitive filesystem, "mv hello.txt Hello.txt" always trigger the "dst already exists" error, because both names refer to the same file to MS-DOS, requiring the user to pass the "--force" option. Allow it without "--force". Overwriting an existing file with "mv hello.txt Hello.txt" on a case sensitive filesystem *is* an unusual operation, and that is the reason why we require "--force" to make sure that the user means it. I have a slight suspicion that the same "mv hello.txt Hello.txt" on a case insensitive filesystem, where two names are known (to the end user of such a filesystem) to refer to the same path would equally be a very unusual thing to do, and such an operation may deserve a similar safety precaution to make sure that the user really meant to do so by requiring "--force". So, I dunno. > bad = _("destination exists"); > if (force) { > /* > diff --git a/t/t6039-merge-ignorecase.sh b/t/t6039-merge-ignorecase.sh > index dfc9f17..a977653 100755 > --- a/t/t6039-merge-ignorecase.sh > +++ b/t/t6039-merge-ignorecase.sh > @@ -35,7 +35,7 @@ test_expect_success 'merge with case-changing rename on both sides' ' > git reset --hard baseline && > git branch -D with-camel && > git checkout -b with-camel && > - git mv --force TestCase testcase && > + git mv TestCase testcase && > git commit -m "recase on branch" && > >foo && > git add foo && -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html